Please enable javascript to use this site.
· OpenID

  1. fanta ✅ (fanta@linuxinthenight.com)'s status on Wednesday, 12-Jun-2019 11:02:27 CEST fanta ✅ fanta ✅
    @netskaven @jordila @ondiz @foo muy bien pero ... vim tiene una cagada que afecta al sistema operativo.

    Pasos para comprobar si estas afectado:

    1) Si tu versión de VI/VIM es inferior a 8.1.1365 puedes estar afectado.
    2) Si es inferior, debes comprobar si tienes activo el modo 'modeline' que explota la vulnerabilidad.

    Entra en VI, y escribe:
    :set modeline?
    (dos puntos espacio en blanco modeline interrogacion)
    Vi te puede devolver 2 respuestas:
    a) nomodeline ==> Perfecto, no estas afectado
    b) modeline ===> Estas afectado. Tranquilo que hay solución !!

    Si tu version de Linux no ha sacado el parche y estas afectado simplemente debes editar el fichero 'vimrc' e incluir las siguientes 2 líneas:
    set modelines=0
    set nomodeline